DaveHope.co.uk

Configuring the Cisco 877W with BE

I recently wanted to update my Cisco knowledge so replaced my old Juniper home router with a Cisco 877W ADSL2+ wireless router. I thought I’d share the config for any other UK BEthere.co.uk users with a static IP address:

!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service internal
!
hostname ROUTER
!
boot-start-marker
boot-end-marker
!
enable password <ENABLE PASSWORD>
!
aaa new-model
!
!
!
!
aaa session-id common
!
!
dot11 syslog
!
dot11 ssid <WIRELESS SSID>
vlan 1
authentication open
authentication key-management wpa
guest-mode
wpa-psk ascii 0 <WPA KEY>
!
ip cef
ip dhcp use vrf connected
!
ip dhcp pool dhcp-lan
network 10.99.99.0 255.255.255.128
default-router 10.99.99.1
dns-server 8.8.8.8
domain-name davehope.co.uk
!
!
ip domain lookup source-interface ATM0
ip domain name davehope.co.uk
ip name-server 8.8.8.8
!
!
!
username admin privilege 15 password 0 <PASSWORD>
!
!
archive
log config
hidekeys
!
!
!
bridge irb
!
!
interface ATM0
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
no atm ilmi-keepalive
dsl operating-mode auto
dsl enable-training-log
dsl noise-margin -3
dsl bitswap both
!
interface ATM0.1 point-to-point
description BEthere ADSL
ip address <STATIC IP> <SUBNET MASK>
ip nat outside
no ip virtual-reassembly
atm route-bridged ip
pvc 0/101
oam-pvc manage
encapsulation aal5snap
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Dot11Radio0
no ip address
!
encryption vlan 1 mode ciphers tkip
!
broadcast-key vlan 1 change 60
!
!
ssid <WIRELESS SSID>
!
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
!
interface Dot11Radio0.1
encapsulation dot1Q 1 native
no cdp enable
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Vlan1
no ip address
bridge-group 1
bridge-group 1 spanning-disabled
!
interface BVI1
ip address 10.99.99.1 255.255.255.128
ip nat inside
no ip virtual-reassembly
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 <GATEWAY ADDRESS>
!
no ip http server
no ip http secure-server
ip nat inside source list 1 interface ATM0.1 overload
!
access-list 1 permit 10.99.99.0 0.0.0.255
!
!
!
control-plane
!
bridge 1 route ip
!
line con 0
no modem enable
line aux 0
line vty 0 4
transport input ssh
!
scheduler max-task-time 5000
ntp clock-period 17175571
ntp server 146.185.21.74
end

Once you’re up and running, log a support call with BeThere and ask them to switch your SNR Profile and that’ll raise the speed above the 14mbps you’ll get without it.

 

PowerConnect vulnerability fixed

Dell have recently released a firmware update for the PowerConnect line of switches to resolve the security vulnerability I discovered.

Firmware version 4.1.0.19 lists the following fix:

Access is allowed to files on the switch without log in permissions required.
If the file name is known, the file can be downloaded through the web browser without having to be logged in.
Corrected the web process to require login credentials before downloading a file.

Looking at the release notes, Dell have certainly had a few problems with these Broadcom switches. Fingers crossed their new Juniper product line has less issues!

You can find the firmware update on the Dell website.

 

Free Avaya IP Office SMDR receiver

I recently needed to log all calls made via one of our Avaya IP Office phone systems (running software version 5). The only way to do this was via a protocol known as SMDR. This is a process by which the phone system sends call data to another service for recording. I put together a quick Windows service to receive this information and output it to CSV format. Here’s an example of the output (please do not call the numbers in the example):

Call Start, Connected Time, Ring Time, Caller, Call Direction, Dialed Number
25/07/2011 08:27:25,37,1,01202222222@93.95.124.7,Inbound,*7849+441202222222
25/07/2011 08:26:54,70,10,01202222222,Inbound,6000
25/07/2011 08:31:25,0,14,6000,Outbound,01202222222
25/07/2011 08:36:42,0,2,6000,Inbound,#Dev Spare
25/07/2011 08:38:13,43,0,6000,Inbound,?Dave Hope
25/07/2011 08:40:16,0,55,6000,Outbound,01202222222

For download and installation information head over to the SMDR Page.